Налаштування vlan на Mikrotik

18 Червня 2018 0 Теґи: , ,

Mikrotik RouterOS, починаючи з версії 6.41, містить нову реалізацію мосту, яка виключає параметр “master-port”. Відповідно, всі конфігурації, в яких використовується “master-port” інтерфейс не будуть працювати, починаючи з зазначеної вище версії RouterOS.

В даному випадку використовується Cloud Router Switch CRS125-24G-1S з RouterOS 6.42.3.
Вхідні дані:

  • vid 9 – користувацький vlan
  • vid 10 – vlan керування, ip-адреса 10.10.10.2/24
  • порти 2-20 – користувацькі,
  • порти 21-24, sfp1 – транкові,
  • порт 1 – безпосереднє керування комутатором.

1. Створюємо міст:

/interface bridge
add name=bridge1 igmp-snooping=no protocol-mode=none

2. Додаємо до створеного мосту vlan керування:

/interface vlan
add interface=bridge1 name=vlan10 vlan-id=10

3. Додаємо всі порти комутатора до мосту:

/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=ether6
add bridge=bridge1 interface=ether7
add bridge=bridge1 interface=ether8
add bridge=bridge1 interface=ether9
add bridge=bridge1 interface=ether10
add bridge=bridge1 interface=ether11
add bridge=bridge1 interface=ether12
add bridge=bridge1 interface=ether13
add bridge=bridge1 interface=ether14
add bridge=bridge1 interface=ether15
add bridge=bridge1 interface=ether16
add bridge=bridge1 interface=ether17
add bridge=bridge1 interface=ether18
add bridge=bridge1 interface=ether19
add bridge=bridge1 interface=ether20
add bridge=bridge1 interface=ether21
add bridge=bridge1 interface=ether22
add bridge=bridge1 interface=ether23
add bridge=bridge1 interface=ether24
add bridge=bridge1 interface=sfp1

4. Додаємо мітки vlan на користувацьких портах (порт 1 – vid 10, порти 2-20 – vid 9):

/interface ethernet switch ingress-vlan-translation
add customer-vid=0 new-customer-vid=10 ports=ether1
add customer-vid=0 new-customer-vid=9 ports=ether2
add customer-vid=0 new-customer-vid=9 ports=ether3
add customer-vid=0 new-customer-vid=9 ports=ether4
add customer-vid=0 new-customer-vid=9 ports=ether5
add customer-vid=0 new-customer-vid=9 ports=ether6
add customer-vid=0 new-customer-vid=9 ports=ether7
add customer-vid=0 new-customer-vid=9 ports=ether8
add customer-vid=0 new-customer-vid=9 ports=ether9
add customer-vid=0 new-customer-vid=9 ports=ether10
add customer-vid=0 new-customer-vid=9 ports=ether11
add customer-vid=0 new-customer-vid=9 ports=ether12
add customer-vid=0 new-customer-vid=9 ports=ether13
add customer-vid=0 new-customer-vid=9 ports=ether14
add customer-vid=0 new-customer-vid=9 ports=ether15
add customer-vid=0 new-customer-vid=9 ports=ether16
add customer-vid=0 new-customer-vid=9 ports=ether17
add customer-vid=0 new-customer-vid=9 ports=ether18
add customer-vid=0 new-customer-vid=9 ports=ether19
add customer-vid=0 new-customer-vid=9 ports=ether20

5. Позначаємо транкові порти:

/interface ethernet switch egress-vlan-tag
add tagged-ports=ether21,ether22,ether23,ether24,sfp1,switch1-cpu vlan-id=9
add tagged-ports=ether21,ether22,ether23,ether24,sfp1,switch1-cpu vlan-id=10

6. Додаємо записи з vid та портами, що робить дійсним трафік vlan на цих портах:

/interface ethernet switch vlan
add ports="ether2,ether3,ether4,ether5,ether6,ether7,ether8,ether9,ether10,eth\
er11,ether12,ether13,ether14,ether15,ether16,ether17,ether18,ether19,ether\
20,ether21,ether22,ether23,ether24,sfp1,switch1-cpu" vlan-id=9
add ports=ether1,ether21,ether22,ether23,ether24,sfp1,switch1-cpu vlan-id=10

7. Додаємо ip-адресу до vlan керування:

/ip address
add address=10.10.10.2/24 interface=vlan10 network=10.10.10.0

8. Після перевірки конфігурації вмикаємо фільтрацію vlan у глобальних налаштуваннях комутатора:

/interface ethernet switch
set drop-if-invalid-or-src-port-not-member-of-vlan-on-ports="ether1,ether2,eth\
er3,ether4,ether5,ether6,ether7,ether8,ether9,ether10,ether11,ether12,ethe\
r13,ether14,ether15,ether16,ether17,ether18,ether19,ether20,ether21,ether2\
2,ether23,ether24,sfp1"

9. Профіт!